Brno Mod 2 Extraction issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Brno Mod 2 Extraction issues

    Well it finally happened to my Brno Mod 2 after 30odd years of faithful service I started having extraction issues (open the bolt and the fired/unfired case just sat in the chamber. I had a bit of a look at the extractors and one had a bit of a burr on it so I though that was more than likely the issue, anyway I pulled the extractors out (simple job) gave the extractor a quick file with the fine honing stone, put it all back together, through a few rounds into the mag and cycled it and still no joy - I though oh bugga, so pulled it apart again and this time bent the clip that holds the extractors in and tried again, still no joy (worked here and there) so next step was to clean the chamber and the 2 holes at the front where the extractors slot into, I gave the chamber a good scrub with Boretech Elimnator and let it sit for a bit then mopped it out and then tried chambering/extracting again, this time it worked fine - as to whether it will be fine extracting a fired case I don't know as yet but will find out this weekend.

    If no joy I will order an extractor kit for it.

    P.S. you don't need to disassemble the complete bolt to remove the extractors, just remove the Cir-clip as per the video.

    Here's a vid of how to pull the bolt down and remove the extractors etc, might be of interest to those who own Brno/CZ's.

    http://www.youtube.com/watch?v=8Ps1aBudD-w

    Cheers
    Whacking Varmints is my passion!

  • #2
    If the Extractors were not working properly the first thing that happens is they would not grab the case rim at all or more likely they will not let it go at all and it just sits there on the bolt face.

    Mine just does generally toss a case out but most times it just flips around in the action and sit's there.

    I know what the trouble is and nothing to do with the Extractor Claw or the opposite one, the Holder Claw ....it's the Bolt Guide underneath the bolt and what it rides on...it's got the Extractor on top of it that is supposed to throw the spent case forward but it wears and stops working properly. If you open your bolt or take it out you will see this at the back of the port opening.

    I am experimenting with shimming the rear of this to raise it slightly. The whole Bolt Guide is held in with the rear magazine screw and it clips over a ledge at the front. It comes out to the rear of the action once the bolt is removed. There are two different types made for the Model 2 .

    I'll be ordering one from Winchester soon as I'm sick of the extraction issue especially when one is trying to shoot match target groups and concentrate on the job at hand and not be pulling spent cases out. It will work if I cycle the bolt quick and hard.

    Comment


    • #3
      Thanks for that Mega,

      Basically the case wasn't extracting at all in the end (it was like the extractors weren't engaging the rim at all) after doing what I said in the above post it now does so not sure what to make of it after your comments.

      I will see how it goes with fired cases and if need be I will revisit your post and see what I can do.

      I just re-read your post I will have a look at it tomorrow - I wonder if my flushing the chamber area has dislodged some crap resulting in it working again?

      Thanks again for the info mate, much appreciated.
      Whacking Varmints is my passion!

      Comment


      • #4
        I replaced the spring on my '73 which solved most of the problems.

        Flushing out the recesses either side of the breech helped as well.

        Comment


        • #5
          Varminator.....mines around the same vintage 34 years on and still good as the day I got it. Timely post however so I might take a close look at it next time its out.

          Comment


          • Varminator
            Varminator commented
            Editing a comment
            I reckon most of the probs with it were due to the wax that are on the bullets - give the chamber a good clean every now and then and it should be good to go. After filing the burr etc and cleaning the receiver etc which didn't fix it completely but a clean of the chamber seems to have fixed it and made it reliable - worth remembering.

        • #6
          Just wondering, did you take the extractor retaining circlip off, and checked the exctractor claws?
          I wouldn't be surprised if one of the extractor 'claws' is broken, and it's usually uderneath the retaining circlip.
          The claw will not fall out, as it sits recessed into the bolt and the circlip holds it in place, so when you visually inspect it, it looks ok.
          You can check that, just by wiggling each claw to see, if there is an unusual amount of movement, there should only be very slight movement, but if one of the claws is broken, it will move a fair bit, and there is your problem.
          The most important thing in life is not knowing everything, it's having the phone number of somebody who does!

          Comment


          • Varminator
            Varminator commented
            Editing a comment
            Originally posted by retired" post=8120
            Just wondering, did you take the extractor retaining circlip off, and checked the exctractor claws?
            I wouldn't be surprised if one of the extractor 'claws' is broken, and it's usually uderneath the retaining circlip.
            The claw will not fall out, as it sits recessed into the bolt and the circlip holds it in place, so when you visually inspect it, it looks ok.
            You can check that, just by wiggling each claw to see, if there is an unusual amount of movement, there should only be very slight movement, but if one of the claws is broken, it will move a fair bit, and there is your problem.
            Hi Retired,

            Yeah mate I pulled it all apart, the extractors are fine, just a burr on one of em - so I gave that a little hone and cleaned it up, cleaned the chamber (heaps of wax etc) also cleaned the slots that the extractors fit into, seems to be working fine (on unfired rounds) I will be testing it out this weekend to see if it's definitely sorted.

            Cheers mate
        Working...
        X