Issues with my Chargemaster

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues with my Chargemaster

    I've been using the chargemaster to through my powder lately, it's been correctly calibrated. I do this each time I turn it on.
    I loaded 10 rounds and tested it using my chronograph and noticed that the fps wasn't the same as what was listed in the book.
    Also, there were huge variances in velocities over all 10.

    I decided to check all the powder throws using my set of scales and found that the chargemaster threw around 4 - 9 gns less than what I'd set it to.
    For example, if I was going for 24.5gns, it would trickle 19.

    Has anyone else experienced this ?

  • #2
    Little more info would help!
    Is it new/old, still under warrantee?
    Did you but it from O/S or Australia?
    Do you have the right power adapter?
    Try the scales on there own, are they working properly without the thrower??
    I've never separated the thrower from the scales but could be a contact/short between the 2??
    Just putting some things out there!

    Comment


    • Guest's Avatar
      Guest commented
      Editing a comment
      Originally posted by Aushunter" post=32646
      Little more info would help!
      Is it new/old, still under warrantee?
      Did you but it from O/S or Australia?
      Do you have the right power adapter?
      Try the scales on there own, are they working properly without the thrower??
      I've never separated the thrower from the scales but could be a contact/short between the 2??
      Just putting some things out there!
      It's new, bought it from the states.
      The scales I'm talking about are the stand alone type that most people usually buy when they first start out reloading.
      Will check out the video Flatlina mentioned and see if that resolves the issue ?

      edit, I just got the reference ... lol

  • #3
    ^^ Indeed.


    Particularly, what year model is it?
    Do not pass GO. Do not collect $200.

    Comment


    • #4
      I've had few of these and if you look on utube under .358 versus Chargemaster you will see what I did to one. I then sent the video to RCBS.

      Regards
      jb

      Comment


      • sportco
        sportco commented
        Editing a comment
        Mine was doing something similar when I was using it under a flouro light...since I replaced that light with a conventional globe light problems gone. I did have explained to me why that happened but cant remember now!! Also, let it warm up for 15 minutes before you use it.
    Working...
    X